RPM Community Forums

Mailing List Message of <popt-devel>

Re: popt-1.13 release

From: Robert Scheck <robert@rpm5.org>
Date: Fri 11 Jan 2008 - 23:35:08 CET
Message-ID: <20080111223508.GA17297@hurricane.linuxnetz.de>
On Fri, 11 Jan 2008, Takao Fujiwara - Tokyo S/W Center wrote:
> Actually I'm not sure what is your problem.
> Which applications do you try?

Using POPT_fprintf(), all umlauts are broken when doing "LANG=de_DE@euro
rpm --help" or "LANG=de_DE@euro kudzu --help". Whenever an umlaut should be
displayed, it isn't and the rest of the line as well. Instead the next line
is displayed. So it looks like to me, that POPT_fprintf() has problems with
non-ASCII characters when the locale isn't a UTF-8 one.

See http://rpm5.org/community/popt-devel/0038.html and following of this
thread (e.g. http://rpm5.org/community/popt-devel/0043.html). Maybe you can
then see what my problem is.

> It seems recently some of modules, GTK, Bonobo and GNOME session, uses 
> goption. When the application uses --help options, it includes the output 
> of both goption and popt.
> goption has the current encoding but popt is UTF-8 then you may encounter 
> the problem.
> Could you apply POPT_fprintf() for popt options only?

I've no matter about the goption/popt handling at all, I'm just seeing this
problem with popt 1.13 on a konsole without GNOME, Bonobo or whatelse.


Greetings,
  Robert
Received on Fri Jan 11 23:35:14 2008
Driven by Jeff Johnson and the RPM project team.
Hosted by OpenPKG and Ralf S. Engelschall.
Powered by FreeBSD and OpenPKG.