RPM Community Forums

Mailing List Message of <popt-devel>

Re: POPT's API has designed in memory leaks. What to do?

From: Wayne Davison <wayned@samba.org>
Date: Mon 07 Jun 2010 - 18:51:44 CEST
Message-ID: <AANLkTin-zif8bBhhc3kpoGsA2Bp0wPvf8kR3AiK_s3zl@mail.gmail.com>
On Mon, Jun 7, 2010 at 9:40 AM, Jeff Johnson <n3npq@mac.com> wrote:

> The added tyrrany of forcing every application that currently has
> -lpopt
> to change to
> -ljdod
> will be rate-determining to adoption (and glacially/tectonically slow imho)
>

For me, if popt 2 is not compatible with popt 1 then I would rather have to
make a conscious choice to upgrade my code (testing it for compatibility),
and having to change the libray name as a part of that is pretty minor.
 Having a possibility for my program to be run-time linked with a library
that is not compatible with what it expects would be very bad, imo.

..wayne..
Received on Mon Jun 7 19:15:18 2010
Driven by Jeff Johnson and the RPM project team.
Hosted by OpenPKG and Ralf S. Engelschall.
Powered by FreeBSD and OpenPKG.