RPM Community Forums

Mailing List Message of <popt-devel>

Re: ARM 64 bit support (aarch64) starting with autoconf 2.69

From: Jeffrey Johnson <n3npq@me.com>
Date: Sun 24 Nov 2013 - 20:26:05 CET
Message-id: <27BFC44A-2D74-490C-A7F1-8AECB23760D2@me.com>

On Nov 24, 2013, at 2:21 PM, Robert Scheck wrote:

> Hello Jeff,
> 
> On Sun, 24 Nov 2013, Jeffrey Johnson wrote:
>> There's perhaps portability issues moving to later AutoFu
>> (but I use autoconf 2.69 all the time in popt).
>> 
>> Likely the easiest fix is to rerun autogen.sh (or use autoreconf):
>> you could just do that on aarch64 as well.
>> 
>> Will that work?
> 
> yes, that will work. I just got this report by the aarch64 team - with the
> pointer that I ideally should work with upstream to get this upstream done
> for the future. It's up to you, I can run autoreconf on downstream as well
> if you like that more.
> 

Heh. POPT needs portability: aarch64 forcing autoconf 2.69 is
gonna need much much more work than in popt upstream,
and advocacy isn't enuf.

73 de Jeff
Received on Sun Nov 24 20:26:19 2013
Driven by Jeff Johnson and the RPM project team.
Hosted by OpenPKG and Ralf S. Engelschall.
Powered by FreeBSD and OpenPKG.