RPM Community Forums

Mailing List Message of <rpm-devel>

Re: %post-script prerequisites

From: Michael Schroeder <mls@suse.de>
Date: Thu 25 Sep 2008 - 15:36:53 CEST
Message-ID: <20080925133653.GB7824@suse.de>
On Thu, Sep 25, 2008 at 02:37:27PM +0200, Pixel wrote:
> Michael Schroeder <mls@suse.de> writes:
> 
> > So A requires B and B has a requires(post) to A? This isn't installable
> > at all, thus it's a packaging bug.
> 
> i don't agree.
> 
> not knowing exactly what rpmlib does, here is how i understand the pb:
> 
> "Requires" is same as "Requires(postrans)", ie if A requires B, it
> doesn't mean B must be installed before A.

It means that B must be installed before A *works* (easiest
case: B is a library).
Thus, if C has a "Requires(post): A" (e.g. C calls A in a post
scriptlet), A must work, so B and A have to be installed before C.

Cheers,
  Michael.

-- 
Michael Schroeder                                   mls@suse.de
SUSE LINUX Products GmbH, GF Markus Rex, HRB 16746 AG Nuernberg
main(_){while(_=~getchar())putchar(~_-1/(~(_|32)/13*2-11)*13);}
Received on Thu Sep 25 15:36:54 2008
Driven by Jeff Johnson and the RPM project team.
Hosted by OpenPKG and Ralf S. Engelschall.
Powered by FreeBSD and OpenPKG.