RPM Community Forums

Mailing List Message of <rpm-devel>

Re: [CVS] RPM: rpm-5_3: rpm/ INSTALL configure.ac

From: devzero2000 <pinto.elia@gmail.com>
Date: Mon 26 Apr 2010 - 22:06:29 CEST
Message-ID: <x2nb086760e1004261306x5ee4c428m8c2dc8713c95c8a6@mail.gmail.com>
On Mon, Apr 26, 2010 at 9:56 PM, Jeff Johnson <n3npq@mac.com> wrote:

> Checking for all headers is likely overkill. One can infer BeeCrypt version
> from the existence (or not) of just a few headers.
>
> E.g.
>    Beecrypt-4.2.1 will have the ripemd256.h headers, earlier versions
> will not.
>
> The other problem is
>        If you _REALLY_ want the AutoFu to work with BeeCrypt 4.2.0,
>        then the ripemd* algorithms need to be re-added to rpmio/*.
>
> The reason is that I cannot support >100 hash algoritms all tied into
>        #ifdef  WITH_FOO
> AutoFu spewage across _FOUR_ crypto libraries. The AutoFu logic
> becaomes more complicated than the actual boiler-plate needed
> to tie into any specific algorithm.
>
> It is not sufficient to check for the api, and eventually the header, used
in the @rpm5.org code ? Look for realisim is the autoconf karma. I think
there is no doubt that they are not wrong. Please, give me a few days to try
to produce something useful for @rpm5.org in this area.

Regards

> hth
>
> 73 de Jeff
>
> On Apr 26, 2010, at 3:15 PM, Eric Veith wrote:
>
> >  RPM Package Manager, CVS Repository
> >  http://rpm5.org/cvs/
> >
>  ____________________________________________________________________________
> >
> >  Server: rpm5.org                         Name:   Eric Veith
> >  Root:   /v/rpm/cvs                       Email:  eveith@rpm5.org
> >  Module: rpm                              Date:   26-Apr-2010 21:15:24
> >  Branch: rpm-5_3                          Handle: 2010042619152300
> >
> >  Modified files:           (Branch: rpm-5_3)
> >    rpm                     INSTALL configure.ac
> >
> >  Log:
> >    Beecrypt pseudo-versioning checks:
> >    - Added header check for beecrypt headers to configure.ac
> >    - Raised minimum beecrypt version to 4.2.1.
> >
> >  Summary:
> >    Revision    Changes     Path
> >    2.128.2.1   +1  -1      rpm/INSTALL
> >    2.432.2.4   +7  -0      rpm/configure.ac
> >
>  ____________________________________________________________________________
> >
> >  patch -p0 <<'@@ .'
> >  Index: rpm/INSTALL
> >
>  ============================================================================
> >  $ cvs diff -u -r2.128 -r2.128.2.1 INSTALL
> >  --- rpm/INSTALL      3 Jan 2010 22:49:43 -0000       2.128
> >  +++ rpm/INSTALL      26 Apr 2010 19:15:23 -0000      2.128.2.1
> >  @@ -29,7 +29,7 @@
> >   POSIX make      mandatory -       -       e.g.
> http://www.gnu.org/software/make/
> >   Perl            mandatory 5.8.0   5.10.0  http://www.perl.com/
> >   POPT            mandatory 1.15    1.15    http://rpm5.org/files/popt/
> >  -BeeCrypt        mandatory 4.2.0   4.2.0
> http://beecrypt.sourceforge.net/
> >  +BeeCrypt        mandatory 4.2.1   4.2.0
> http://beecrypt.sourceforge.net/
> >   PCRE            mandatory 7.0     7.9     http://www.pcre.org/
> >   Mozilla NSS     optional  3.11    3.11.7
> http://www.mozilla.org/projects/security/pki/nss/
> >   OpenSSL         optional  0.9.8   0.9.8k  http://www.openssl.org/
> >  @@ .
> >  patch -p0 <<'@@ .'
> >  Index: rpm/configure.ac
> >
>  ============================================================================
> >  $ cvs diff -u -r2.432.2.3 -r2.432.2.4 configure.ac
> >  --- rpm/configure.ac 25 Apr 2010 14:21:16 -0000      2.432.2.3
> >  +++ rpm/configure.ac 26 Apr 2010 19:15:23 -0000      2.432.2.4
> >  @@ -1216,6 +1216,13 @@
> >       if test ".$WITH_BEECRYPT" = .no; then
> >            AC_MSG_ERROR([BEECRYPT is mandatory])
> >       fi
> >  +    AC_CHECK_HEADERS([beecrypt/api.h beecrypt/base64.h
> beecrypt/beecrypt.h dnl
> >  +        beecrypt/dsa.h beecrypt/endianness.h beecrypt/md4.h
> beecrypt/md5.h dnl
> >  +        beecrypt/mp.h beecrypt/mpbarrett.h beecrypt/ripemd128.h dnl
> >  +        beecrypt/ripemd160.h beecrypt/ripemd256.h beecrypt/ripemd320.h
> dnl
> >  +        beecrypt/rsa.h beecrypt/rsapk.h beecrypt/sha1.h
> beecrypt/sha224.h dnl
> >  +        beecrypt/sha256.h beecrypt/sha384.h beecrypt/sha512.h], [],
> >  +        [ AC_MSG_ERROR([Your version of BEECRYPT is too old.]) ])
> >
> >   dnl # GCrypt
> >   RPM_CHECK_LIB(
> >  @@ .
> > ______________________________________________________________________
> > RPM Package Manager                                    http://rpm5.org
> > CVS Sources Repository                                rpm-cvs@rpm5.org
>
> ______________________________________________________________________
> RPM Package Manager                                    http://rpm5.org
> Developer Communication List                        rpm-devel@rpm5.org
>
Received on Mon Apr 26 22:11:54 2010
Driven by Jeff Johnson and the RPM project team.
Hosted by OpenPKG and Ralf S. Engelschall.
Powered by FreeBSD and OpenPKG.