RPM Community Forums

Mailing List Message of <rpm-devel>

distepoch problem with latest snapshot of 5.2

From: Matthew Dawkins <mattydaw@gmail.com>
Date: Fri 14 Jan 2011 - 19:05:06 CET
Message-ID: <AANLkTi=DczOBXf4taEMqrQ8a2P_+MPWNGmTh0BnnP+9F@mail.gmail.com>
I recently updated my snapshot of 5.2 to build around a perl upgrade to
5.12.2, but I didn't expect any problems really.
Well pkgs that have requires like the following:
Provides:   libpq = %{version}-%{release}

now also have this half distepoch after it :2011.1

made with a newer rpm5.2 snapshot
rpm -qp --provides lib64pq8.4_5-8.4.5-3-
unity2011.0.x86_64.rpm
postgresql-libs = 8.4.5-3
libpq = 8.4.5-3
lib64pq8.4_5-virtual = 8.4
libpq.so.5()(64bit)
*lib64pq8.4_5 = 8.4.5-3:2011.0*

made with the older rpm5.2 snapshot
rpm -qp --provides lib64pq8.4_5-8.4.4-3-unity2010.x86_64.rpm
postgresql-libs = 8.4.4-3
libpq = 8.4.4-3
lib64pq8.4_5-virtual = 8.4
libpq.so.5()(64bit)
*lib64pq8.4_5 = 8.4.4-3*
Received on Fri Jan 14 19:05:23 2011
Driven by Jeff Johnson and the RPM project team.
Hosted by OpenPKG and Ralf S. Engelschall.
Powered by FreeBSD and OpenPKG.