RPM Community Forums

Mailing List Message of <rpm-users>

Re: "rpmdeps" not not working

From: Eric MSP Veith <eveith@wwweb-library.net>
Date: Wed 11 Jul 2007 - 23:11:37 CEST
Message-Id: <200707112311.37789.eveith@wwweb-library.net>
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hello,

I just rebuilt rpm-4.4.8. I took great care that nothing disturbed the build:
- - Clean environment variables,
- - no ccache, distcc, parallel make,
- - removed the old rpmdeps manually before installing the newly build packages

However, rpmdeps still doesn't print out the dependencies expeded. I noticed 
that the genereation of perl dependencies works:

$ echo /usr/lib/perl5/5.8.8/Net/FTP.pm | /usr/lib/rpm/rpmdeps -R
perl >= 0:5.001
perl(Carp)
perl(Fcntl)
perl(IO::Socket)
(...)
rpmlib(VersionedDependencies) <= 3.0.3-1

Likewise for Python or shell scripts:

$ echo /usr/lib/python2.4/Queue.py | /usr/lib/rpm/rpmdeps -R
python(abi) = 2.4

$ echo /etc/init.d/rc.font.new | /usr/lib/rpm/rpmdeps -R
/bin/sh

Perhaps the file magic examination fails?

> Send me a ptr to the *.src.rpm of what you are calling rpm-4.4.8 if
> you get stuck,

I used the src.rpm from rpm5.org, located here: 
http://rpm5.org/files/rpm/rpm-4.4/rpm-4.4.8-1.src.rpm

> and I'll try to figger what broke.

Thanks alot for your help! :-)

	Eric
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.7 (GNU/Linux)

iD8DBQFGlUeJfkUtd7QNU/sRAsJvAKDDE8FAaoN/AczaAbnipHCzn1kvSgCgkKoJ
wH9Os+6frDy0YHlrlw46WIA=
=z3Ii
-----END PGP SIGNATURE-----
Received on Wed Jul 11 23:11:46 2007
Driven by Jeff Johnson and the RPM project team.
Hosted by OpenPKG and Ralf S. Engelschall.
Powered by FreeBSD and OpenPKG.