RPM Community Forums

Mailing List Message of <rpm-users>

Re: error: cannot open Packages database in /var/lib/rpm

From: Jeff Johnson <n3npq@mac.com>
Date: Fri 27 Jul 2007 - 19:47:01 CEST
Message-Id: <F39ECD06-A40E-4AAD-88A4-1A66D8E0467F@mac.com>

On Jul 26, 2007, at 3:51 PM, Robert Scheck wrote:

> Ideas? I was using rpm 4.5-0.3 switched to -0.4 and switched back  
> to -0.3
> after that I've this or very similar errors for every rpmdb action.
>
> # rpm -vvv -qa
> D: dbiOpen: _dbiapi failed
> error: cannot open Packages database in /var/lib/rpm
> #
>

I've produced a "make dist" rpm-4.5 tar ball (because the rpm.spec  
needs adjustment)
of what is currently installed (and working) for me.

That tarball will be the start of rpm-4.5, and I hope to have -0.5  
binary packages Sunday
night or Monday morning.

73 de Jeff
Received on Fri Jul 27 19:46:59 2007
Driven by Jeff Johnson and the RPM project team.
Hosted by OpenPKG and Ralf S. Engelschall.
Powered by FreeBSD and OpenPKG.