RPM Community Forums

Mailing List Message of <rpm-users>

Re: rpm-5.0.0: usage of --root or --prefix while installing an rpm package -- not working ?

From: Jeff Johnson <n3npq@mac.com>
Date: Tue 15 Jan 2008 - 17:32:34 CET
Message-Id: <5F2933F2-1AC4-4F6F-BF15-A16B40432C06@mac.com>

On Jan 15, 2008, at 11:00 AM, Stefan Westmeier wrote:

The root cause of your problem is this
     Dirnames: /if/sys/most                                  NEIND
	package most_if-1.0-1.i686 has unsatisfied Dirnames: /if/sys/mostD

The easiest "fix" is to add --noparentdirs to disable dependencies of
files on their parent directories when installing.

One can also add the directory skeleton to a package
(distros usually do this in a "filesystem" package), or
for your chroot-in-homedir usage case, create the
list of directories in the file tree skeleton in (this
is the default path, can be changed through configuration)
     /etc/rpm/sysinfo/Dirnames

I'd also suggest (if working with --root) to configure

     #       Open all indices before doing chroot(2).
     #
     %_openall_before_chroot 1

in ~/.rpmmacros or wherever else is convenient.

73 de Jeff
Received on Tue Jan 15 17:35:36 2008
Driven by Jeff Johnson and the RPM project team.
Hosted by OpenPKG and Ralf S. Engelschall.
Powered by FreeBSD and OpenPKG.