RPM Community Forums

Mailing List Message of <rpm-users>

Headers, librpm*: compatibility with rpm-4.4.x

From: Peter Volkov <pva@gentoo.org>
Date: Thu 17 Jan 2008 - 08:31:20 CET
Message-Id: <1200555080.17466.101.camel@localhost>
Hello.

I would like to ask is there any compatibility with with rpm-4.4.x? The
problem is that some (all I'm aware about: sussen[1], net-snmp) programs
which compiled fine with rpm-4.4.x stoped compile with rpm-5.x. But
seems that the problem is not with library API itself, at least I found
required definitions in headers, but the problem is that rpm 5.0 headers
does not include system headers like sys/types.h and etc...

So the questions are: is there any backward compatibility with rmp-4.x
supposed to be in rpm-5.x? If it is supposed, how to link with librmp*?

Thank you in advance for your answer(s).

References:
[1] http://bugs.gentoo.org/205280
[2] http://bugs.gentoo.org/202399

-- 
Peter.



Received on Thu Jan 17 13:15:57 2008
Driven by Jeff Johnson and the RPM project team.
Hosted by OpenPKG and Ralf S. Engelschall.
Powered by FreeBSD and OpenPKG.