RPM Community Forums

Mailing List Message of <rpm-users>

rpm-5.0.0: dependency / requirements check during install / update

From: Stefan Westmeier <stefan_westmeier@hotmail.de>
Date: Thu 24 Jan 2008 - 17:34:04 CET
Message-ID: <BAY115-W255AFA8C52A2306F323A6098380@phx.gbl>

Hi, I am not shure whether this is the right list, but I try. Please let me know, if I should post to other list or other place. Seems that check of required packages is not working in rpm 5.0.0 during install and update. I have a package most_if-1.0-1.i686.rpm. I created some packages for test purposes: 
most-bin-1.0-1.i686.rpm                     Requires: most_if = 1.0most-bin-1.0-1-req-1.1.i686.rpm          Requires: most_if = 1.1most-bin-1.0-1-req-0.9.i686.rpm          Requires: most_if = 0.9
rpm 5.0.0 installs every combination of most_if with one of the most-bin packages!!
E.g the following command works without complains.

rpm --relocate /if=/home/user/SWDev/rpmroot/if \
    --relocate /sys=/home/user/SWDev/rpmroot/sys \
    -U most_if-1.0-1.i686.rpm most-bin-1.0-1-req-1.1.i686.rpm
rpm -V -a afterwards correctly reports about not fullfilled dependencies.
Doing the same with rpm 4.1, rpm refuses to install the ones with non matching dependencies.
Ist this a bug or a feature?
Packages can be download here:
URL:                 https://stefanwestmeier.mediencenter.t-online.de/fotomgr/coma/index.clsemail:               rpm-users@rpm5.orgpassword:         rpm
Received on Thu Jan 24 17:34:06 2008
Driven by Jeff Johnson and the RPM project team.
Hosted by OpenPKG and Ralf S. Engelschall.
Powered by FreeBSD and OpenPKG.