RPM Community Forums

Mailing List Message of <rpm-users>

_dbiapi failed when doing "rpm --initdb" on RPM 4.4.6

From: Eric MSP Veith <eveith@wwweb-library.net>
Date: Sun 17 Feb 2008 - 16:56:36 CET
Message-Id: <200802171656.36882.eveith@wwweb-library.net>
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hello,

im currently doing my own distribution, it's somewhat LFS, for my company's 
special needs. I had not yet the time to migrate to RPM 5, so I plan to 
stick with 4.4.6 for the time beeing.

So, I've started the system with a boot CD, installed everything via 
rpm2cpio at first until I got a basic system. I re-mounted /proc, /dev 
and /sys and chroot()ed to my new installation to set up the RPM database. 
When running "rpm --initdb", nothing happens and the directory stays 
empty. "rpm -qa" of course then shows an error message: "Cannot open 
packages database in /var/lib/rpm".

Running "rpm --initdb -vv" shows the following: "D: dbiOpen: _dbiapi 
failed"; same error message when I run "rpm -qa -vv".

I've no clue what RPM tries to tell me with that. :-( Needed libraries (db, 
sqlite, neon, ...) are installed, ldconfig runs without problems, and any 
other program does not complain. I could even compile and install a kernel.

Can you give my any pointers on where to search?

Thanks alot in advance.

	Eric
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.7 (GNU/Linux)

iD8DBQFHuFk0fkUtd7QNU/sRAigcAJ47H9lEZAPnlPij4nM4j5vZ5hQOPACdGsI4
yomlsERO5afsgiabMeLkuo4=
=fIHm
-----END PGP SIGNATURE-----
Received on Sun Feb 17 17:25:03 2008
Driven by Jeff Johnson and the RPM project team.
Hosted by OpenPKG and Ralf S. Engelschall.
Powered by FreeBSD and OpenPKG.