RPM Community Forums

Mailing List Message of <rpm-users>

Database compatibility with older versions?

From: Martin Nicolay <m.nicolay@osm-gmbh.de>
Date: Mon 10 Mar 2008 - 10:32:41 CET
Message-ID: <Pine.LNX.4.63.0803101031050.7781@wsmn.osm-gmbh.de>
Hi!

Is there a way to archive database compatibility with older versions (rpm4 
/ rpm3)?  We need to support many different Linux and SunOS versions and 
would like to use the same packaging software for all systems.  
Unfortunately we have used the rpm proliferated by the distro for our own 
software, so the system-packages and our own packages are within the same 
database.  If we use the new and shiny rpm5 for updates of our software, 
hell breaks loose for system updates (unless database compatibility es 
archived).

Martin Nicolay.

-- 
_______________________________________________________________________________
No MS-Word attachments (http://www.gnu.org/philosophy/no-word-attachments.html)

OSM GmbH                               Mail    m.nicolay@osm-gmbh.de
- Softwareentwicklung -                Telefon +49-201/8955-5
Ruhrallee 191                          Fax     +49-201/8955-400
D-45136 Essen                          Web     http://www.osm-gmbh.de

Registergericht: Amtsgericht Essen, HRB 11281
Geschäftsführer: Johannes Kuhn, Christian Damsky, Axel Roland
_______________________________________________________________________________
Received on Mon Mar 10 11:43:19 2008
Driven by Jeff Johnson and the RPM project team.
Hosted by OpenPKG and Ralf S. Engelschall.
Powered by FreeBSD and OpenPKG.