RPM Community Forums

Mailing List Message of <rpm-users>

Re: Problem w/ Configure of RPM 5.0.3 on Solaris 8

From: Jeff Johnson <n3npq@mac.com>
Date: Tue 01 Apr 2008 - 01:12:52 CEST
Message-Id: <353D5AEF-5FFB-4E7E-A373-986B5DE83D31@mac.com>

On Mar 31, 2008, at 12:17 PM, Eliyahu Skoczylas wrote:

> I'm having a problem with the BeeCrypt check for RPM 5.0.3.  I have
> indeed installed BeeCrypt 4.1.2 as part of my new installation of  
> RPM 5
> on a SunOS 5.8 box, but the ./configure script gives me the following:
>
>   checking beecrypt/api.h usability... yes
>   checking beecrypt/api.h presence... yes
>   checking for beecrypt/api.h... yes
>   checking for mpfprintln in -lbeecrypt... no
>   checking whether to build with BeeCrypt library... no
>   configure: error: mandatory BeeCrypt library not found
>
> Something about the mpfprintln() call not compiling / linking  
> correctly.
>  I will get back to tracking this tomorrow (I'm on UTC+2 + DST) but I
> thought that if anyone could come up with a suggestion it would  
> save me
> some time and trouble.  Bad library paths?  Missing include?  Compiler
> flags?
>
> FWIW,
>
> % uname -a
> SunOS SV650 5.8 Generic_108528-09 sun4u sparc SUNW,Sun-Blade-100
>
>

Can you examine config.log in the top of the rpm build tree and see why
     ...
     checking for mpfprintln in -lbeecrypt... no
     ...

failed please?

73 de Jeff
Received on Tue Apr 1 01:13:47 2008
Driven by Jeff Johnson and the RPM project team.
Hosted by OpenPKG and Ralf S. Engelschall.
Powered by FreeBSD and OpenPKG.