RPM Community Forums

Mailing List Message of <rpm-users>

Re: Problem w/ Configure of RPM 5.0.3 on Solaris 8

From: Eliyahu Skoczylas <EliSko@Eli-Sko.com>
Date: Tue 01 Apr 2008 - 11:52:49 CEST
Message-Id: <1207043569.14967.1245396781@webmail.messagingengine.com>
Thanks for replying.  I'm attaching the config.log from the point of the
BeeCrypt tests, in case there's something else to look at, but I'm
pretty sure that this is all we need to know:

| configure:36348: checking for mpfprintln in -lbeecrypt
| configure:36383: gcc -o conftest -g -O2 -D_GNU_SOURCE -D_REENTRANT 
-DRPM_OS_SOLARIS=020800 -I/usr/local/include  conftest.c -lbeecrypt 
-lpthread -lrt -lsocket -lnsl
-L/usr/local/BerkeleyDB.4.6/lib:/usr/local/lib/sparcv9:/usr/local/lib
>&5
| Undefined                       first referenced
|  symbol                             in file
| __eprintf                          
/usr/local/lib/gcc/sparc-sun-solaris2.8/3.4.6/../../../libstdc++.so.6
| ld: fatal: Symbol referencing errors. No output written to conftest
| collect2: ld returned 1 exit status

Looks like there's something messed up in my link librariee, their
search order, or who knows what.  I'll look into it and keep you posted.

Thanks again,

-    Eliyahu 

-- 
  Eliyahu Skoczylas    Computer Consultant
  +972 (54) 659-4445   <EliSko@Eli-Sko.com>

----- Original message -----
From: "Jeff Johnson" <n3npq@mac.com>
To: rpm-users@rpm5.org
Date: Mon, 31 Mar 2008 19:12:52 -0400
Subject: Re: Problem w/ Configure of RPM 5.0.3 on Solaris 8


On Mar 31, 2008, at 12:17 PM, Eliyahu Skoczylas wrote:

> I'm having a problem with the BeeCrypt check for RPM 5.0.3.  I have
> indeed installed BeeCrypt 4.1.2 as part of my new installation of  
> RPM 5
> on a SunOS 5.8 box, but the ./configure script gives me the following:
>
>   checking beecrypt/api.h usability... yes
>   checking beecrypt/api.h presence... yes
>   checking for beecrypt/api.h... yes
>   checking for mpfprintln in -lbeecrypt... no
>   checking whether to build with BeeCrypt library... no
>   configure: error: mandatory BeeCrypt library not found
>
> Something about the mpfprintln() call not compiling / linking  
> correctly.
>  I will get back to tracking this tomorrow (I'm on UTC+2 + DST) but I
> thought that if anyone could come up with a suggestion it would  
> save me
> some time and trouble.  Bad library paths?  Missing include?  Compiler
> flags?
>
> FWIW,
>
> % uname -a
> SunOS SV650 5.8 Generic_108528-09 sun4u sparc SUNW,Sun-Blade-100
>
>

Can you examine config.log in the top of the rpm build tree and see why
     ...
     checking for mpfprintln in -lbeecrypt... no
     ...

failed please?

73 de Jeff
______________________________________________________________________
RPM Package Manager                                    http://rpm5.org
User Communication List                             rpm-users@rpm5.org
Received on Tue Apr 1 11:52:51 2008
Driven by Jeff Johnson and the RPM project team.
Hosted by OpenPKG and Ralf S. Engelschall.
Powered by FreeBSD and OpenPKG.