RPM Community Forums

Mailing List Message of <rpm-users>

Re: Help: Installing RPM on Solaris 8

From: Mark Hatle <mark.hatle@windriver.com>
Date: Wed 09 Apr 2008 - 17:39:02 CEST
Message-ID: <47FCE316.5010007@windriver.com>
It's been a few years, but this is what I had to do to get to RPM 4.4.2. 
  We needed to provide a "modern" gcc, binutils, autoconf, automake, 
libtool, etc.. as well as libraries and such.

RPM 5.x should be a little easier to configure for solaris.. but many of 
the tools are very old and that will cause issues.

--Mark

Eliyahu Skoczylas wrote:
> I've been trying to install either RPM 4.3.3 or RPM 5.0.3 on Solaris 8
> and running into all kinds of trouble.
> 
> Is anyone out there actually using a version of RPM later than 3 on
> Solaris 8?  If so, I'd like some advise / suggestions on getting it set
> up.  A link to a binary would be ideal, but some advice about tools for
> building from source would also be welcome.
> 
> I keep running into "dependency problems", needing a newer version of
> gcc, which needs gmake, which needs newer runtime libraries, which needs
> ....  It ends up that I'm building half the GNU repository in iterations
> from version to version to bootstrap my way into being able to build
> RPM, and I feel like there should be an easier way.
> 
> Anyone?
> 
> 
> TIA - Thanks In Advance,
> 
> -    Eliyahu
Received on Wed Apr 9 21:30:20 2008
Driven by Jeff Johnson and the RPM project team.
Hosted by OpenPKG and Ralf S. Engelschall.
Powered by FreeBSD and OpenPKG.