RPM Community Forums

Mailing List Message of <rpm-users>

Re: Help: Installing RPM on Solaris 8

From: Tim Mooney <mooney@dogbert.cc.ndsu.NoDak.edu>
Date: Wed 09 Apr 2008 - 23:04:48 CEST
Message-ID: <alpine.SOC.1.10.0804091558060.22782@dogbert.cc.ndsu.NoDak.edu>
In regard to: Re: Help: Installing RPM on Solaris 8, Eliyahu Skoczylas said...:

> Jeff Johnson wrote:
>> On Apr 9, 2008, at 3:33 PM, Eliyahu Skoczylas wrote:
>>> 4.4.9 would best keep us in sync with the CentOS version 4.3.3 that another 
>>> team member has started playing with, and should be most interoperable in 
>>> terms of of .spec files.
>> Not true. There are already significant changes in rpm-4.4.9 that
>> are very different than rpm-4.3.3.
>
> I was under the (perhaps mistaken) impression that if the Linux team wrote 
> .spec files that ran under 4.3.3 / Linux that they should run pretty well 
> under 4.4.9 / Solaris.

If you write your spec files to work with rpm 4.3.3, rpm 4.4.9 shouldn't
have any problem with them.  Neither should 5.0.3.  It would be more of
a problem to write your spec files for 5.0.3 and then try use them with
4.3.3.

If it would help, I can try figure out all the software I had to install
before I got rpm 4.4.9 to build.  The list is longer for Solaris 8 than
it was for Solaris 10.  I was just operating under the assumption that
the list was fairly well documented in 5.0.3.

Tim
-- 
Tim Mooney                              mooney@dogbert.cc.ndsu.NoDak.edu
Information Technology Services         (701) 231-1076 (Voice)
Room 242-J6, IACC Building              (701) 231-8541 (Fax)
North Dakota State University, Fargo, ND 58105-5164
Received on Wed Apr 9 23:19:42 2008
Driven by Jeff Johnson and the RPM project team.
Hosted by OpenPKG and Ralf S. Engelschall.
Powered by FreeBSD and OpenPKG.