RPM Community Forums

Mailing List Message of <rpm-users>

Re: Compiling RPM against Python 2.6

From: Jeff Johnson <n3npq@mac.com>
Date: Tue 14 Oct 2008 - 19:23:59 CEST
Message-id: <2A3F7F9B-1F18-4DF5-9887-D308B961218F@mac.com>

On Oct 14, 2008, at 1:16 PM, Eric MSP Veith wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> This mail hopefully ends my "spam" :-)
>
> I see that RPM as of 5.1.5 compiles against Python 2.5, but not  
> against 2.6.
> This version was released quite recently, sure. I recall the the API
> changes between 2.5 and 2.6 are relatively small, so I'll try to  
> compile
> RPM with Python 2.6, but: Would you recomend downgrading to the 2.5.x
> branch?
>

Patch for python 2.6 was added by bero to HEAD a couple of days ago.

Change configure.ac to add 2.6 as a possible version, not hard.

ANd yous "spam" contains questions while my "spam"
contains tpyo corrections. No worries ...

73 de Jeff
Received on Tue Oct 14 19:24:30 2008
Driven by Jeff Johnson and the RPM project team.
Hosted by OpenPKG and Ralf S. Engelschall.
Powered by FreeBSD and OpenPKG.