RPM Community Forums

Mailing List Message of <rpm-users>

Migrating from rpm-4.4.8 to rpm-5.1.6

From: Eric MSP Veith <eveith@wwweb-library.net>
Date: Tue 21 Oct 2008 - 15:11:39 CEST
Message-Id: <200810211311.43048.eveith@wwweb-library.net>
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hello,

yesterday I finally found the time to wrap up my own RPM package and upgrade 
to the latest stable version. The goal was to provide a seamless upgrade 
for some of my old systems that sill use RPM version 4.4.6 and 4.4.8.

I configured RPM with the following command (just for reference):
%configure \
        --with-libelf \
        --with-perl \
        --with-python \
        --with-zlib \
        --with-bzip2 \
        --with-lzma \
        --with-beecrypt \
        --with-file=internal \
        --with-db=internal \
        --with-sqlite=external \
        --with-db-largefile \
        --with-dbapi=db \
        --with-lua=internal \
        --with-pcre \
        --with-xar=internal \
        --with-path-macros='%{_libdir}/rpm/macros:
%{_sysconfdir}/rpm/macros.d/*:
~/.rpmmacros' \
        --with-db-tools-integrated \
        --enable-build-pic \
        --enable-build-pie

The rest of the build and install section follows the example spec file from 
the source distribution. I only left the path once with my own macro path 
argument, providing my own vendor macro file.

After the installation, I ran a "rpm -qa" to see what happens. It worked 
quite will, RPM only spit out some warnings: "retrieved corrupted header". 
My package list itself was complete, though. I used "rpm --rebuilddb" 
hoping that this would fix the error, and yes, it did.

So, all in all, no upgrade problems here.

I hope this was useful.

Thanks for RPM 5,
		-- Eric
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iEYEARECAAYFAkj91QsACgkQfkUtd7QNU/tSUwCeO5151iIHFiBiZ9oys0tPBDJe
FpwAn2/6JzuSqQIPupO6zIucXL4raknH
=ETPd
-----END PGP SIGNATURE-----
Received on Tue Oct 21 15:11:45 2008
Driven by Jeff Johnson and the RPM project team.
Hosted by OpenPKG and Ralf S. Engelschall.
Powered by FreeBSD and OpenPKG.