RPM Community Forums

Mailing List Message of <rpm-users>

upgrading from rpm 4.4 to rpm 5

From: JD <jd1008@gmail.com>
Date: Sat 13 Dec 2008 - 08:50:19 CET
Message-ID: <4943693B.8050602@gmail.com>
How do I safely upgrade from rpm 4.4 to rpm 5
without destroying my current databse?

On one system, the rpm database has become unusable
after the upgrade.
To wit:
# rpm -qa
rpmdb: Program version 4.3 doesn't match environment version
error: db4 error(-30974) from dbenv->open: DB_VERSION_MISMATCH: Database 
environment version mismatch
error: cannot open Packages index using db3 -  (-30974)
error: cannot open Packages database in /var/lib/rpm

How do I recover from this??
Received on Sat Dec 13 09:13:18 2008
Driven by Jeff Johnson and the RPM project team.
Hosted by OpenPKG and Ralf S. Engelschall.
Powered by FreeBSD and OpenPKG.