RPM Community Forums

Mailing List Message of <rpm-users>

Re: Migrating from rpm-4.4.8 to rpm-5.1.6

From: Jeff Johnson <n3npq@mac.com>
Date: Mon 15 Dec 2008 - 22:56:55 CET
Message-id: <61E3DBF9-18C0-4C63-AF19-10DDE7A3DE17@mac.com>

On Dec 15, 2008, at 4:39 PM, Eric MSP Veith wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> Hello,
>
> sorry for the long delay.
>
> You should try the following things:
>
> - - Check whether these requirements are hard-coded in you vendor's  
> spec
> files. You can get the spec from the SRPMS, for example.
> - - Use rpm2cpio to extract the rpm5 packages. Set LD_LIBRARY_PATH  
> and try
> accessing your existing RPM database
> - - Manually replace the old rpm using --force --nodeps
>
> In any case, be sure to have backups of both your old packages and  
> your rpm
> database, the latter as tar archive and as textual version created  
> with
> rpm -qa > list.txt!
>
> HTH
> 		-- Eric
>
> On Saturday 13 December 2008, JD <jd1008@gmail.com> wrote:
>> I am having a hard time with rpm -ivh or -Uvh.
>> rpm -Uvh rpm-5.0-0.2.0.fc7.rf.x86_64.rpm
>> error: Failed dependencies:
>>        getconf(GNU_LIBPTHREAD_VERSION) = NPTL is needed by
>> rpm-5.0-0.2.0.fc7.rf.x86_64
>>        librpm-5.0.so()(64bit) is needed by  
>> rpm-5.0-0.2.0.fc7.rf.x86_64
>>        librpm-5.0.so(LIBRPM_0)(64bit) is needed by
>> rpm-5.0-0.2.0.fc7.rf.x86_64
>>        librpmdb-5.0.so()(64bit) is needed by  
>> rpm-5.0-0.2.0.fc7.rf.x86_64
>>        librpmdb-5.0.so(LIBRPMDB_0)(64bit) is needed by
>> rpm-5.0-0.2.0.fc7.rf.x86_64
>>        librpmio-5.0.so()(64bit) is needed by  
>> rpm-5.0-0.2.0.fc7.rf.x86_64
>>        librpmio-5.0.so(LIBRPMIO_0)(64bit) is needed by
>> rpm-5.0-0.2.0.fc7.rf.x86_64
>>        rpm = 4.4.2.2-2.fc7 is needed by (installed)
>> rpm-libs-4.4.2.2-2.fc7.i386
>>        rpm = 4.4.2.2-2.fc7 is needed by (installed)
>> rpm-python-4.4.2.2-2.fc7.x86_64
>>        rpm = 4.4.2.2-2.fc7 is needed by (installed)
>> rpm-devel-4.4.2.2-2.fc7.i386
>>        rpm = 4.4.2.2-2.fc7 is needed by (installed)
>> rpm-devel-4.4.2.2-2.fc7.x86_64
>>        rpm = 4.4.2.2-2.fc7 is needed by (installed)
>> rpm-build-4.4.2.2-2.fc7.x86_64
>>        /bin/rpm is needed by (installed)
>> policycoreutils-2.0.16-16.fc7.x86_64
>>

Note also that rpm-5.0-0.2.0 from "fc7.rf" is rather ancient
history, packaged before rpm-5.0 even started, a couple of
weel's after @rpm5.org was organized.

Latest "production" release @rpm5.org is rpm-5.1.6.

An @rpm5.org chooses "vendor neutral" releases by policy, so you
(or someone else) will have to build binary *.rpm packages with
whatever feature set you want, there's way too many vendor changes
to chase producing per-vendor-distro-ready binary *.rpm packages.

OTOH, the poicy @rpm5.org can be changed to produce binary *.rpm
packages whenever there is sufficient interest.

But that is not rpm-5.0-0.2.0.fc7.rf.x86_64.rpm any more ...

hth

73 de Jeff

  • application/pkcs7-signature attachment: smime.p7s
Received on Mon Dec 15 22:58:11 2008
Driven by Jeff Johnson and the RPM project team.
Hosted by OpenPKG and Ralf S. Engelschall.
Powered by FreeBSD and OpenPKG.