RPM Community Forums

Mailing List Message of <rpm-users>

error: cannot open Packages database in /var/lib/rpm

From: <spam.spam.spam.spam@free.fr>
Date: Tue 26 May 2009 - 19:50:58 CEST
Message-ID: <1243360258.4a1c2c026f9e1@imp.free.fr>
Hello,

I have installed : rpm 5.1.9, bash 3.2, db-4.4.20, ncurses-5.6, beecrypt-4.1.2,
gcc-4.4.0 and glibc-2.9 in a directory.

I did :
sudo chroot /my/directory

Then I try to install a RPM package :
# rpm -i 8Kingdoms-1.1.0-6.fc9.i386.rpm
error: cannot open Packages database in /var/lib/rpm
warning: 8Kingdoms-1.1.0-6.fc9.i386.rpm: Header V3 DSA signature: NOKEY, key ID
4f2a6fd2
error: cannot open Packages database in /var/lib/rpm

It's a problem...
So I did :
# rpm --initdb
# rpm --rebuilddb
error: cannot open Packages database in /var/lib/rpm

I am root:root user:group and the rigts on /var/lib/rpm are :
$ ls -ld tmp/var/lib/rpm
drwxrwxrwx 2 root root 48 2009-05-26 15:39 tmp/var/lib/rpm

The directory /var/lib/rpm stay empty...

Why I got these errors?

Thank you.
Received on Tue May 26 19:51:20 2009
Driven by Jeff Johnson and the RPM project team.
Hosted by OpenPKG and Ralf S. Engelschall.
Powered by FreeBSD and OpenPKG.