RPM Community Forums

Mailing List Message of <rpm-users>

Re: Spaces in filenames in a spec file???

From: Jeff Johnson <n3npq@mac.com>
Date: Sat 11 Jul 2009 - 00:57:50 CEST
Message-id: <DC3F5ABE-EB21-469A-84F2-66F949E72BB0@mac.com>

On Jul 10, 2009, at 6:32 PM, devzero2000 wrote:

> On Fri, Jul 10, 2009 at 9:25 PM, Michael Lasevich <michael@lasevich.net 
> > wrote:
> I need to package an rpm that contains files with spaces in them.   
> Sounds like it should be easy, but I am completely stuck. I tried  
> the backslash escape, I tried putting the filename in double quotes  
> - nothing seems to work. I ran into this a number of times over the  
> years and normally I would just rename the file, but in this  
> particular case that is not an option.
>
> I can't believe that rpm cannot handle this, which means there has  
> to be an escape scheme that I am missing here. Google turned up zilch.
>
> Any help would be appreciated.
>
> If it matters, I am using rpm-4.4.2.3-9.el5
>
> SIA. Not problem at all to answer BUT perhaps you have written to  
> the wrong mailing list ? This is RPM5 : some years of development  
> have passed from rpm 4.4.2.x.y.z. Just for curiosity.


Well the answer is gonna be the same.

Either use globs in %files to never mention white space.

Or insert the file path within double quotes "...".

73 de Jeff
Received on Sat Jul 11 01:59:19 2009
Driven by Jeff Johnson and the RPM project team.
Hosted by OpenPKG and Ralf S. Engelschall.
Powered by FreeBSD and OpenPKG.