RPM Community Forums

Mailing List Message of <rpm-users>

Regrading error = error: removing * "Requires: *" from tsort relations.

From: Manoj Palhade <mpalhade@googlemail.com>
Date: Thu 27 Aug 2009 - 14:57:28 CEST
Message-ID: <67f63fb0908270557l3fe55e52i702550d2d9c37744@mail.gmail.com>
Dear Team,



I am new this rpm group and just now started development (port) of rpm on
QNX RTOS.



I build spec file and tried to install it on QNX. But during installation I
am getting following errors.



***************************************************************

error: LOOP:
error: removing rpmTest-1.0-0.x86pc "Requires: /" from tsort relations.

**********************************************************************************

I tried to debug the code and I found following (may be wrong) things in
"\rpm-5.1.9\lib\depends.c" file.


Above error occurs in zapRelation() which is called in rpmtsOrder().


I want to know can i comment following line in rpmtsOrder().
dp = zapRelation(q, p, 1, &nzaps, msglvl);

As 3rd parameter in zapRelation() is set to  1(constant  magic number)
which always throw error (2nd line from above error).


Please let me know your opinion and let me know if i am wrong. I haven't
understood purpose of zapRelation() please give more detail's.



Thanks and Regards,
Manoj Palhade
Received on Thu Aug 27 15:54:10 2009
Driven by Jeff Johnson and the RPM project team.
Hosted by OpenPKG and Ralf S. Engelschall.
Powered by FreeBSD and OpenPKG.