RPM Community Forums

Mailing List Message of <rpm-users>

Re: error: cannot open Packages database in /opt/sys/var/lib/rpm

From: Manoj Palhade <mpalhade@googlemail.com>
Date: Mon 05 Oct 2009 - 13:53:04 CEST
Message-ID: <67f63fb0910050453id6a1da2ra612f3a41df95b2a@mail.gmail.com>
Dear Jens,

Thanks for your reply. I have following requirement to port RPM on QNX.


   1. I have to build RPM on one machine and then copy-past it to other QNX
   machines(it is more that 10+) as I said previously (to install rpm on QNX
   RTOS; I copied bin and lib folder from root folder to /opt/sys/ folder of
   QNX.). It is not possible as per requirement that I have to compile and
   build each time for each QNX running machine. Copy-Past should work with out
   any problem.

 As per your communication there are 2 ways to do this

   1. Compile and Build with some option (I am not sure which option to use
   to compile and build RPM). This is OK as compilation and build is one time
   task.


   1. Change paths in macro configuration. Is it in QNX OS file or in RPM
   File? If it is in RPM File then it is possible as change paths in macro
   configuration is one time task (Please let me know the filename) but if it
   in QNX OS file then it is not possible because of as per requirement.

So please let me know which option I need to use to compile and build RPM
for first time so that I can do above task.

Thanks and Regards,
Manoj Palhade

On Thu, Oct 1, 2009 at 6:52 PM, Jeff Johnson <n3npq@mac.com> wrote:

>
>  On Oct 1, 2009, at 7:18 AM, Manoj Palhade wrote:
>
>   Hi,
>
>  I want to install rpm on QNX RTOS. For this purpose I copied bin and lib
> folder from root folder to /opt/sys/ folder of QNX.
>
>
> You likely need to change paths in macro configuration, almost all paths
> used by RPM are in configuration, not compiled into RPM. So you
> also need to change the configuration when moving executables.
>
>  And I tried to execute basic command like #rpm qa & #rpm Uvh
> rpmtest-1.1-1.x86pc.rpm
>
>  But I am getting following error for each and every command.
>
> *error: cannot open Packages database in /opt/sys/var/lib/rpm*
>
>
> The first step is to add -vv (or use strace) to see what paths RPM is
> trying to use.
>
>   I also tried to execute command # rpm -initdb. It is working fine.
>
>
> The --initdb option doesn't really initialize anything and isn't really
> needed or
> useful.
>
>   Please help me to resolve this error. Also do I need to copy var folder
> also.
>
>
> Perhaps easiest would be to rebuild rpm and with the paths you want to use.
>
> By copying, you are almost certainly going to have to override compiled in
> paths with additional CLI arguments using a shell wrapper.
>
> 73 de Jeff
>
Received on Mon Oct 5 14:00:20 2009
Driven by Jeff Johnson and the RPM project team.
Hosted by OpenPKG and Ralf S. Engelschall.
Powered by FreeBSD and OpenPKG.