RPM Community Forums

Mailing List Message of <rpm-users>

error: failed to open /etc/mnttab: No such file or directory

From: Manoj Palhade <mpalhade@googlemail.com>
Date: Thu 26 Nov 2009 - 08:36:40 CET
Message-ID: <67f63fb0911252336x64f9da55j44bac365d9b589ad@mail.gmail.com>
Dear RPM Team,



I tried to install RPM Package on QNX with RPM 5.1.9



I am getting following “error message” but RPM Package get installed
successfully after this error message also.

error: failed to open /etc/mnttab: No such file or directory



I tried to debug code and following is the finding

Follwing code at line no 168 in \lib\fs.c file is gives above “error
message”

mtab = fopen(MOUNTED, "r"); //

if (!mtab) {

    rpmlog(RPMLOG_ERR, _("failed to open %s: %s\n"), MOUNTED,

               strerror(errno));

    return 1;

}



MOUNTED is defined at line 712 in system.h



#ifndef MOUNTED

#define MOUNTED "/etc/mnttab"

#endif



I haven’t understood the purpose of this MOUNTED.

This MOUNTED is not used anywhere in RPM source code.



On my QNX if I create folder mnttab at /etc/ then no error message” appears
while installing RPM Package



Thanks and Regards,
Manoj Palhade
Received on Thu Nov 26 08:36:58 2009
Driven by Jeff Johnson and the RPM project team.
Hosted by OpenPKG and Ralf S. Engelschall.
Powered by FreeBSD and OpenPKG.