RPM Community Forums

Mailing List Message of <rpm-users>

Performance Testing & Size Limit RPM Package

From: Manoj Palhade <mpalhade@googlemail.com>
Date: Tue 22 Dec 2009 - 12:43:03 CET
Message-ID: <67f63fb0912220343n39d5dfc8mf432d6b16546d867@mail.gmail.com>
Dear RPM Team,

I am doing Performance testing of RPM on My Target (QNX as an OS). I am
trying to install RPM Package of size 100 MB. This RPM Package contains zip
file of 100 MB. Time taken by RPM to install this 100 MB package is 3.10s;
which I believe is wrong for 100 MB rpm package. I haven’t seen Zip file got
copied after installation. I found following file at destination location
“Test100.zip;000000fa”. I tried to remove this file but I am not able to
remove it.
I tried same Testing in VMWare Session where QNX is installed; it is working
file. I can see zip file of RPM Package getting copied.

Is there any limitation on size of RPM Packages and File inside the RPM
Packages.

Another problem I am getting as follow.

I am getting following error when I try to un-nstall RPM Packages
error: cannot create %_repackage_dir /opt/sys/var/spool/repackage/88817

# rpm -e Test25-1.0-1
error: cannot create %_repackage_dir /opt/sys/var/spool/repackage/1430

# rpm -e Test20-1.0-1
error: cannot create %_repackage_dir /opt/sys/var/spool/repackage/1445

Last folder name (88817) varies each time. How to avoid this error. Is this
error is because of Fat16 file system.

Thanks and Regards,
Manoj Palhade
Received on Tue Dec 22 12:43:21 2009
Driven by Jeff Johnson and the RPM project team.
Hosted by OpenPKG and Ralf S. Engelschall.
Powered by FreeBSD and OpenPKG.