RPM Community Forums

Mailing List Message of <rpm-users>

Re: package foo-1.1.1.x86_64.rpm is intended for a x86_64 architecture

From: Jeff Johnson <n3npq@mac.com>
Date: Wed 12 May 2010 - 22:20:37 CEST
Message-id: <4355BE0D-4466-435E-8923-2F2DB2F70E8E@mac.com>

On May 12, 2010, at 2:55 PM, Marc MERLIN wrote:

>> 
>> Any idea how I can tell the new rpm to rely on my arch as in uname -m as
>> opposed to whatever else it is doing?
> 
> Oh, I forgot, 
> eou15:/tmp# rpm -qRp foo-1.1.1.x86_64.rpm 
> monitoring  
> rpmlib(CompressedFileNames) <= 3.0.4-1
> rpmlib(PayloadFilesHavePrefix) <= 4.0-1
> 
> The binary does require a 64libc, but I have one.
> 

Hint: If you want to see all the metadata to, say, diagnose
which tags contain what, try adding --xml.

73 de Keff
Received on Wed May 12 22:21:14 2010
Driven by Jeff Johnson and the RPM project team.
Hosted by OpenPKG and Ralf S. Engelschall.
Powered by FreeBSD and OpenPKG.