RPM Community Forums

Mailing List Message of <rpm-users>

Issues with rpm-5.0.3 - overwrites other RPM's

From: Robert Cohen <robertc99@gmail.com>
Date: Fri 23 Jul 2010 - 05:04:13 CEST
Message-ID: <4C4906AD.2000002@gmail.com>
   Hi,

   We've built, and had been using for years, our own instance of rpm 
4.0.3, and it worked a treat. Our platform was Solaris 8/9/10, on sparc.

   Recently, we started using solaris10 on x86, and figured it was a 
good time to upgrade our rpm environment.


   I got 5.2.1 built, but something weird is happening. When we install 
rpm's that we produce within the rpm environment, the rpm installation 
silently overwrites files belonging to other rpms rather than detecting 
conflicts.  rpm seems to pay attention to prerequisites, and conflicts 
specified in the SPEC, but rpm --install/--upgrades will 
delete/overwrite files that were installed via rpm.

I also tried version 5.0.3 but same problems.

  This seems quite ironic to me given the most recent message on this 
list is bout how to get rpm to overwrite files of other packages.

   Even the build process for rpm5  seemed dodgy, as I had to do things 
like  copy in find-provides, find-requires, and configure them into the 
macros file by hand.


   I've spent far too long fighting this, and am about to give up, and 
revert to a build of 4.0.3 for our solaris 10x86 systems, but really 
didn't want to do that.

   The build of 5.0.3/5.2.1 was against gcc 3.4.3, using GNU make, and 
involved the  installlation of beecrypt, zlib, and popt from 3rd party 
sources, into  /usr/local/rpm, before attempting to build rpm as I have 
been unable to get the copies distributed with RPM to build.
Received on Fri Jul 23 05:37:01 2010
Driven by Jeff Johnson and the RPM project team.
Hosted by OpenPKG and Ralf S. Engelschall.
Powered by FreeBSD and OpenPKG.