RPM Community Forums

Mailing List Message of <rpm-users>

Re: Issues with rpm-5.0.3 - overwrites other RPM's

From: Jeff Johnson <n3npq@mac.com>
Date: Fri 23 Jul 2010 - 05:56:46 CEST
Message-id: <B33965A4-967A-484C-AFAC-D60BF63C6F1A@mac.com>

On Jul 22, 2010, at 11:04 PM, Robert Cohen wrote:

>  Hi,
> 
>  We've built, and had been using for years, our own instance of rpm 4.0.3, and it worked a treat. Our platform was Solaris 8/9/10, on sparc.
> 
>  Recently, we started using solaris10 on x86, and figured it was a good time to upgrade our rpm environment.
> 
> 
>  I got 5.2.1 built, but something weird is happening. When we install rpm's that we produce within the rpm environment, the rpm installation silently overwrites files belonging to other rpms rather than detecting conflicts.  rpm seems to pay attention to prerequisites, and conflicts specified in the SPEC, but rpm --install/--upgrades will delete/overwrite files that were installed via rpm.
> 

Show me a reproducer and I'll diagnnose. The behavior you claim (I'm
not doubting what you see) has an explanation.

> I also tried version 5.0.3 but same problems.
> 
> This seems quite ironic to me given the most recent message on this list is bout how to get rpm to overwrite files of other packages.
> 

RPM is expected to meet may conflicting expectations. I'm not
sure what the most recent message here is/was.

>  Even the build process for rpm5  seemed dodgy, as I had to do things like  copy in find-provides, find-requires, and configure them into the macros file by hand.
> 

RPM has an overly complex build yes. This is in fact what was
asked for after much discussion.

I personally find "Have it your own way!" configuration with the immense amount
of AutoFu (like >30 configure options) both difficult to achieve reliably/reproducibly, and
with some very surprising results.

E.g. its quite possible to build @rpm5.org code with an utterly useless end-result:
	No compression, no database, nothing rationale compiled into RPM.

But I most definitely support the consensus policy @rpm5.org even if the results
of "Have it your own way!" build configuration are ... not desirable.

> 
>  I've spent far too long fighting this, and am about to give up, and revert to a build of 4.0.3 for our solaris 10x86 systems, but really didn't want to do that.
> 

So ask instead of fighting. I will assist diagnosing any reported issue.

rpm-4.0.3 is only like 9-10 years old. At least try rpm-4.0.5, that's
the last/best release in the 4.0.x series.

>  The build of 5.0.3/5.2.1 was against gcc 3.4.3, using GNU make, and involved the  installlation of beecrypt, zlib, and popt from 3rd party sources, into  /usr/local/rpm, before attempting to build rpm as I have been unable to get the copies distributed with RPM to build.
> 

Show me the configuration options and I'll attempt to diagnose.

That's really all I can offer.

73 de Jeff
Received on Fri Jul 23 05:57:13 2010
Driven by Jeff Johnson and the RPM project team.
Hosted by OpenPKG and Ralf S. Engelschall.
Powered by FreeBSD and OpenPKG.