RPM Community Forums

Mailing List Message of <rpm-users>

Re: Issues with rpm-5.0.3 - overwrites other RPM's

From: Tim Mooney <Tim.Mooney@ndsu.edu>
Date: Fri 23 Jul 2010 - 21:12:51 CEST
Message-ID: <alpine.SOC.2.01.1007231345530.18518@dogbert.cc.ndsu.NoDak.edu>
In regard to: Issues with rpm-5.0.3 - overwrites other RPM's, Robert Cohen...:

>  We've built, and had been using for years, our own instance of rpm 4.0.3, 
> and it worked a treat. Our platform was Solaris 8/9/10, on sparc.

I did the same with rpm 2.5.6 and then 4.4.[679].

>  Recently, we started using solaris10 on x86, and figured it was a good time 
> to upgrade our rpm environment.

I do a lot of building on x86_64-pc-solaris2.10.  I upgraded to rpm 5.1.9
about 4 months ago.  Joshua Burns' post from December 4th, 2009 had some
useful tips on build issues with 5.x, so I as prepared for most of what
I ran into.

>  I got 5.2.1 built, but something weird is happening. When we install rpm's 
> that we produce within the rpm environment, the rpm installation silently 
> overwrites files belonging to other rpms rather than detecting
> conflicts.  rpm seems to pay attention to prerequisites, and conflicts
> specified in the SPEC, but rpm --install/--upgrades will
> delete/overwrite files that were installed via rpm.

Hmmm, I've not seen that with 5.1.9.  With one very minor exception, 5.1.9
built pretty easily and the upgrade process from 4.4.9 to 5.1.9 worked
without a hitch, which I wasn't really expecting.

I had issues with the dependency generator not finding ELF library
provides correctly after the update, but discovered that was because
5.1.9 doesn't build with libelf support by default (you have to request
it).  Once I did that and then hacked out tools/debugedit so that wasn't
built, everything worked very well.

>  Even the build process for rpm5  seemed dodgy, as I had to do things like 
> copy in find-provides, find-requires, and configure them into the macros file 
> by hand.

I don't remember having to do any of that.  I certainly customized a macro
or two, but nothing major.

>  The build of 5.0.3/5.2.1 was against gcc 3.4.3, using GNU make, and involved 
> the  installlation of beecrypt, zlib, and popt from 3rd party sources, into 
> /usr/local/rpm, before attempting to build rpm as I have been unable to get 
> the copies distributed with RPM to build.

I built my own copies of stuff beforehand in many cases.  I'm using
the Sun Workshop 12u1 compilers, so if anything your builds should have
been easier.  I probably had the most trouble getting rpm to use my
copy of neon, but that's because neon builds static libraries only by
default and there's no good way for RPM's configure to discover that neon
depends on things like libssl and libkrb5.

I'm not sure what's going on with your 5.2.1, but it's definitely
unexpected.  I know for a fact that the 5.1.9 I have installed will
complain if I try to install an RPM that would overwrite files from a
different package.

I would say continue down the 5.2.1 path, posting specific questions and
errors you encounter to the list.  I should be able to provide suggestions
for any build issues you run into.

Getting an example of what's going on with the silent overwriting would
also be helpful.  I'm thinking of something like

 	rpm -q -l packageA
 	rpm -q -f /file/from/packageA/you/know/will/be/overwritten
 	rpm -vv -ivh packageB.rpm
 	rpm -q -l packageB
 	rpm -q -f /file/from/packageA/you/know/will/be/overwritten

Jeff will likely have better debugging suggestions, but this should be
an easy thing to start with.

Tim
-- 
Tim Mooney                                             Tim.Mooney@ndsu.edu
Enterprise Computing & Infrastructure                  701-231-1076 (Voice)
Room 242-J6, IACC Building                             701-231-8541 (Fax)
North Dakota State University, Fargo, ND 58105-5164
Received on Fri Jul 23 21:27:13 2010
Driven by Jeff Johnson and the RPM project team.
Hosted by OpenPKG and Ralf S. Engelschall.
Powered by FreeBSD and OpenPKG.