RPM Community Forums

Mailing List Message of <rpm-users>

Re: Does %files support -foo ?

From: Charlie Brady <charlieb-rpm5.org@budge.apana.org.au>
Date: Sat 06 Nov 2010 - 04:11:13 CET
Message-ID: <Pine.LNX.4.64.1011052256490.943@e-smith.charlieb.ott.istop.com>

On Fri, 5 Nov 2010, Marc MERLIN wrote:

> > Caveat:
> >    %exclude has some minor issues in various versions of RPM.
>  
> I tried it, it worked for
> 
> %files
> /*

I'd advise you to be more selective in what dirs you allow your rpm to 
claim ownership of. Don't claim ownership of directories you don't 
install. I've seen bad things happen when an rpm has wrong perms on a top 
level directory - e.g. wrong permissions on /tmp is a bad thing.

> %exclude /etc/init.d
> 
> but I can't re-add:
> /etc/init.d/file
> 
> It was worth a shot.
> 
> > In my experience, its just as simple to switch to a manifest using
> > 	%files -f manifest
> > 
> > Generate the manifest at end of %install, and filter paths however you
> > wish with sed/grep/cut/awk/whatever.
> 
> Yep, seems like the way to go.

I agree with Jeff this is the way to go if you don't want to hand-craft 
the list.
Received on Sat Nov 6 15:11:36 2010
Driven by Jeff Johnson and the RPM project team.
Hosted by OpenPKG and Ralf S. Engelschall.
Powered by FreeBSD and OpenPKG.