RPM Community Forums

Mailing List Message of <rpm-users>

Re: Re: Compile Problems on FreeBSD 8.2

From: <vrwmiller@gmail.com>
Date: Mon 13 Jun 2011 - 17:08:41 CEST
Message-ID: <90e6ba6e8fdc7784dd04a5994b0d@google.com>
Thanks, Jeff. I ended up going with option 1 and got RPM5 to compile and  
build on Friday.

On , Jeff Johnson <n3npq@mac.com> wrote:


> On Jun 13, 2011, at 10:56 AM, Eric MSP Veith wrote:



> >>

> >> />/usr/home/vmiller/rpm-5.3.4/misc/.libs/librpmmi= sc.so: undefined

> >> reference to GSS_C_NT_HOST=

> >> BASED_SERVICE'
> *** Error code 1

> Stop in

> >> /usr/home/vmill= er/rpm-5.3.4/tools.
> *** Error code 1

> >> />Stop in /usr/home/vmil= ler/rpm-5.3.4/tools.
> *** Error code 1
> >> />
> Stop in /usr/home/vmi= ller/rpm-5.3.4.
> *** Error code 1
> >> />
> Stop in /usr/home/vmiller/= rpm-5.3.4.

> >>



> This one bites me all the time 



>  neon can be compiled with or without GSSAPI and every vendor/distro  
> handles

> slightly differently.



> There's 3 approaches to getting a build to work:



> 1) add the libraries that internal neon needs using LIBS= or LDFLAGS=

> before invoking ./configure



> 2) add the neon flag that explicitly disables GSSAPI support



> 3) build against external system neon, not with the internal neon



> Both 1) and 2) assume --with-neon=internal, 3) passes  
> --with-neon=external.



> hth



> 73 de Jeff



Received on Mon Jun 13 17:08:42 2011
Driven by Jeff Johnson and the RPM project team.
Hosted by OpenPKG and Ralf S. Engelschall.
Powered by FreeBSD and OpenPKG.