RPM Community Forums

Mailing List Message of <rpm-users>

Re: rpm-5.0.0 and ftp / http support

From: Rolf Pedersen <rolfpedersen@mindspring.com>
Date: Sat 10 Dec 2011 - 04:06:11 CET
Message-ID: <4EE2CCA3.4070108@mindspring.com>
On 12/09/2011 06:22 PM, Jeffrey Johnson wrote:
>
> On Dec 9, 2011, at 9:02 PM, Rolf Pedersen wrote:
>
>> Mandriva 2011.0
>> [rolf@localhost ~]$ cat /etc/mandriva-release
>> Mandriva Linux release 2011.0 (Official) for x86_64
>> [rolf@localhost ~]$ rpm -q rpm
>> rpm-5.3.12-0.20110712.2-mdv2011.0.x86_64
>>
>> This is my first exposure to rpm-5 and I couldn't understand why I 
>> couldn't rpm -qip [--changelog] URL or rpm -U --oldpackage URL, some 
>> rpm functionalities I've come to use often, after 11 years of 
>> Mandrake|iva.  This thread is the first suggestion of the reason I've 
>> found, after some fruitless google searching and devising some 
>> testing to eliminate local 
>> corruption:https://qa.mandriva.com/show_bug.cgi?id=64914
>>
>> Is "network access was disabled in rpm-5.0.0" why I am seeing this?  
>> If so, can the functionalities be restored?
>
> Its likely the reason, yes. But there's quite a few years of history
> between the report and mdv2011 so I cannot say for sure.
>
> It is the same means to re-enable
>> Then "opt-in" to network access by doing
>>
>>      echo "%_rpmgio        %{nil}" >> /etc/rpm/macros
>
> If you run into problems, add -vv --rpmiodebug --ftpdebug (which will
> be a lot of output) and post a pointer here and I'll sort out
> what isn't working.
>
> The fundamental problem is that its impossible to support
> functionality like network transport as "opt in" enabling,
> particularly when linux vendors and users insist on disabling
> the functionality.
>
> 73 de Jeff
The original thread contained a patch but I did not attempt to 
apply/rebuild anything, fyi. http://rpm5.org/community/rpm-users/0075.html

echo "%_rpmgio        %{nil}" >> /etc/rpm/macros

[rolf@localhost Public]$ cat /etc/rpm/macros
# Put your own system macros here
# usually contains

# Set this one according your locales
# %_install_langs

%_rpmgio        %{nil}
[rolf@localhost Public]$

I did not log out/in, did not think it necessary?  Behavior seemed 
unchanged from as reported in bug: 
https://qa.mandriva.com/show_bug.cgi?id=64914

[rolf@localhost ~]$  rpm -qip 
ftp://mirrors.kernel.org/mandrake/Mandrakelinux/official/2011/x86_64/media/main/updates/apache-conf-2.2.21-0.1-mdv2011.0.x86_64.rpm 

error: open of 
ftp://mirrors.kernel.org/mandrake/Mandrakelinux/official/2011/x86_64/media/main/updates/apache-conf-2.2.21-0.1-mdv2011.0.x86_64.rpm 
failed: No such file or directory
[rolf@localhost ~]$

Ran debug command:

[rolf@localhost Public]$  rpm -qip 
ftp://mirrors.kernel.org/mandrake/Mandrakelinux/official/2011/x86_64/media/main/updates/apache-conf-2.2.21-0.1-mdv2011.0.x86_64.rpm 
-vv --rpmiodebug --ftpdebug 2>&1 | tee ftpdebug.txt

Output is here:
http://dl.dropbox.com/u/1286780/ftpdebug.txt

Thanks,
Rolf
Received on Sat Dec 10 04:06:15 2011
Driven by Jeff Johnson and the RPM project team.
Hosted by OpenPKG and Ralf S. Engelschall.
Powered by FreeBSD and OpenPKG.