RPM Community Forums

Mailing List Message of <rpm-users>

Re: rpm fatal error on osx el capitan

From: Jeffrey Johnson <n3npq@me.com>
Date: Wed 30 Sep 2015 - 22:50:07 CEST
Message-id: <BB1F856B-966F-49CA-99B4-E9C54120D1F3@me.com>

> On Sep 30, 2015, at 4:32 PM, Anders F Björklund <afb@rpm5.org> wrote:
> 
> Jacques Knipper wrote:
> 
>> Indeed I'm talking about v5.4.15.
>> I didn't try with the --rpmdbdebug yet but I will, thanks.
>> The problem happen with every rpm.
>> I am able to rebuild our rpms with the rpmbuild, but I cannot install them, an I think it's because of an issue with Berkeley DB.
> 
> FWIW, the issue was reproducible on Mavericks too. You need to install something to see it, though...
> 
> So the default test case a) looks a bit broken and b) doesn't actually test installing and erasing ?
> 
> %_topdir		#{testpath}/var/lib/rpm
> 
> I think it is something with the (lack of) configuration, that is getting the rpmdb in a sad state.
> 

Hmmm … I’d likely concur lack of configuration (and that rpmdb is overly complex).

Meanwhile:

	Is this a segfault or an assertion failure using rpm?

I haven’t seen the exact error message ….

If the problem is a segfault, then there may be an assertion missing someplace.

And if some assertion exit is common (which is likely the case imho)
to an out-of-box misconfigured experience, perhaps an exit by invoking an
opaque script to display a per-platform tuned message might assist.

Of course the opaque script generation through AutoFu may just introduce
Yet Mode Configuration failures, sigh.

Is the problem a segfault or an assertion failure?

73 de Jeff
> --anders______________________________________________________________________
> RPM Package Manager                                    http://rpm5.org
> User Communication List                             rpm-users@rpm5.org
Received on Wed Sep 30 22:50:19 2015
Driven by Jeff Johnson and the RPM project team.
Hosted by OpenPKG and Ralf S. Engelschall.
Powered by FreeBSD and OpenPKG.