RPM Community Forums

Mailing List Message of <rpm-users>

rpm fatal error on osx el capitan

From: Jacques Knipper <jacques.knipper@dalim.com>
Date: Thu 24 Sep 2015 - 15:40:19 CEST
Message-ID: <5603FD43.9050905@dalim.com>

I already know that brew and rpm are not officially supported on latest 
version of osx for now...
I noticed when I installed rpm with brew that rpm is suffixed with 
"_el_capitan_bottle", so I allow myself to ask you about an issue I'm 
facing, maybe someone is working on it :)

When we tried to install any rpm with "sudo rpm -ivh ...", the command 
crash with an error "error: db3cput:db3.c:1461: dbcursor->put(-30973): 
BDB0087 DB_RUNRECOVERY: Fatal error, run database recovery".

I tried to remove any db files and run rebuilddb but that's not better...

We also tried to install both of rpm and berkeley-db in debug to step 
in, but we do not find any relevant information that help us to get out 
of this bad situation...
Have you any idea why we are able to install all the stuff but not using it?

Thanks :)


Jacques Knipper
Software Engineer
t. +49 7851 91 96 23 <tel:+49%207851%2091%2096%2023>
f. +49 7851 73 57 6 <fax:+49%207851%2073%2057%206>

Strassburger Strasse 6
77694 Kehl, Germany
www.dalim.com <http://www.dalim.com/>


Geschäftsführer: Dr. Carol Werlé (CEO)
Vorsitzender des Aufsichtsrats (Chairman): Jim D. Salmon
Ust-IdNr. (VAT-Nr.): DE 195 290 616
Sitz der Gesellschaft (Location): Kehl, Amtsgericht Freiburg, HRB 371620
Received on Thu Sep 24 16:37:33 2015
Driven by Jeff Johnson and the RPM project team.
Hosted by OpenPKG and Ralf S. Engelschall.
Powered by FreeBSD and OpenPKG.