RPM Community Forums

Mailing List Message of <rpm-users>

Re: rpm fatal error on osx el capitan

From: Anders F Björklund <afb@rpm5.org>
Date: Thu 24 Sep 2015 - 20:41:52 CEST
Message-Id: <E6433862-1529-4703-BCD9-D7366596A843@rpm5.org>
Jacques Knipper wrote:

> I already know that brew and rpm are not officially supported on latest version of osx for now...

Whatever official support is, I don't think it is happening on *any* version of OS X. But that particular system version is not even released yet, for another week or so...

> I noticed when I installed rpm with brew that rpm is suffixed with "_el_capitan_bottle", so I allow myself to ask you about an issue I'm facing, maybe someone is working on it :)

Can't say I have any plans to work on it. But the homebrew build is pretty standard, so it should be more or less the same as just building it from release (5.4.15) ?

> When we tried to install any rpm with "sudo rpm -ivh ...", the command crash with an error "error: db3cput:db3.c:1461: dbcursor->put(-30973): BDB0087 DB_RUNRECOVERY: Fatal error, run database recovery".
> I tried to remove any db files and run rebuilddb but that's not better...

Sounds like you have a problem with Berkeley DB ? It seems that you (i.e. brew) is using version 6.1.26.

You can also run with additional -v flags, to get some more debugging information. And also --rpmdbdebug.

> We also tried to install both of rpm and berkeley-db in debug to step in, but we do not find any relevant information that help us to get out of this bad situation...

Seems like you didn't get far enough to really create a situation, if the first rpm installation crashed on you ?

> Have you any idea why we are able to install all the stuff but not using it?

Depends on what you are trying to use it for. Did you plan on doing anything else, after unpacking with brew ?

I think the only scenario being tested by the build bot, is being able to make an .rpm and possibly to inspect an empty db:


A more extensive test, like installing and erasing packages is probably a good idea - *if* one is planning to use rpm for that...

Seems like my /var/lib/rpmbuild hack didn't even make it to the next commit (f386026)

Received on Thu Sep 24 20:44:18 2015
Driven by Jeff Johnson and the RPM project team.
Hosted by OpenPKG and Ralf S. Engelschall.
Powered by FreeBSD and OpenPKG.